Komodo 11 "Go to Definition" and CodeIntel Issues

Hi Team!

I’m having a few issues with Komodo 11 (11.0.1, on Windows 10 FCU), and I was hoping that you guys might have some suggestions or fixes. Just as general info, before I launch into it, I’m coding in PHP, with some HTML and JavaScript as needed.

The first issue that I’m having is that the “Go to Definition” option no longer works on any of my PHP functions. It worked perfectly in Komodo 9, it mostly worked in Komodo 10 (though it became 50/50 towards the end), but in Komodo 11 all I get is the message “Could not find definition”. It doesn’t matter if I’m working in a massive project, with thousands of files, or in a small project, with less than 100 files. In fact, even if the function is in the same file that I’m working in, it still says “Could not find definition”.

The next issue that I’m having has to do with using classes, in PHP. Anytime I use the -> operator, hoping that CodeIntel will pull up a list of the functions and variables in that object, I get nothing. This issue doesn’t happen when I’m working in the class itself, and using the $this-> variable, only when using an object of that class elsewhere in the project. Again, like the last issue, it worked fine in Komodo 10, but Komodo 11 gives me nothing. It kind of feels like this issue is related to the last one, almost like it’s having trouble scanning files or something.

And the last issue that I’m having is with CodeIntel suggestions when working in HTML. It often won’t give me the closing tag suggestion. So, for example, lets say that I’m coding a form, and I’m going to close that form, I type </ expecting that it’ll suggest </form> for me. Instead, it doesn’t suggest anything at all…until I finally type </form> myself. Right after I type the > at the end of it, then it finally suggests the </form> tag. This issue isn’t that much of a big deal to me, but thought it worth mentioning, just in case.

Both of the first two issues are causing me to have to use the heck out of the find feature, when working in larger projects (which I’m happy to say that the find feature is working wonderfully well). However, having to do a full find search really hampers my work flow, so I was hoping that you guys might be able to help me out. If you need me to provide you with any additional information, I would be happy to do so.

Thank you!

We have had reports of these kinds of issues, but the only thing that really helps is a concrete test case (e.g. a small project with some sample code that causes the issue), instead of a simple “it doesn’t work any more”. We have a large number of internal test cases for “go to definition” and member completions that all pass. Obviously there are cases we have not accounted for, and we are very interested in finding them, but we need your help! :slight_smile:

Thank you for your reply, Mitchell. I understand completely. Can’t fix a problem if you can’t see it happening.

I’ll work to put together a small sample project that exhibits the issues. Unfortunately, it’ll be after November 19th before I’ll be able to do this, as I’ll be out of the office for the next week or so at a convention. But as soon as I’m back, I’ll put this together.

Once I do have it ready, how would you like me to provide it? Should I open a bug ticket and provide the information and project there? Or link the file here?

Please open a bug ticket with links and/or attachments to your files/project. Thanks so much!

Hi, I’m currently reviewing Komodo IDE for personal projects and am having a similar issue to the one described in the initial post.

Specifically, it seems like “Go to Definition”, calltips and completions only work for classes and functions that are explicitly referenced with one of “use”, “require”, “require_once”, “include” or “include_once” statements. When these exist throughout the codebase, codeintel works as would be expected.

When the project does not use namespaces or include/require statements (non PSR-4 autoloader), codeintel seems to ignore symbols that aren’t in the current files context. This occurs after successful scanning and has no resulting error output in the codeintel3.log file.

This leads me to believe that I cannot work on any codebase with a non PSR-4 autoloader. Please correct me if I am wrong because I am a few days into the trial and this is my only complaint, albeit a deal breaker.

I’m happy to do further testing if there is an “debug level output” setting I can enable to provide more information.

Hi, this will be fixed in Komodo 11.1. Komodo will offer project-wide PHP autocompletion without the need for explicit “require” statements.

@careyh do we have an 11.1 nightly build available for download?

I’m not Carey (though I wish I had his beard), but I don’t see 11.1 nightly builds on downloads.activestate.com.

@mitchell, no nightly available right now, no.

Hi ,
I am facing the same issue .

I am using Komodo IDE, version 11.0.2, build 90813, platform linux-x86_64.
Built on Mon Dec 4 10:20:45 2017.

As its been four months now. I am hoping we have an update. Please advice.

Thank you,

A nightly would be much appreciated. I upgraded to 11 in January and lack of completion / code intel (python) has been very frustrating.

@Vishal_Khialani, the fix will be available in Komodo 11.1. There is no word on when we will do a nightly/beta release for Komodo 11.1. We’ll try to remember to posts to this thread when we release. Otherwise watch the forums for an announcement around that.

@concussinogfx, I don’t think this issue should be affecting Python. It was specifically for PHP but I might be wrong. @mitchell, could you correct me if I’m wrong?

  • Carey

@careyh This would not affect Python. As far as I know, Python should be working fine as long as the proper paths are set. The only definitions you cannot jump to are Python stdlib definitions.

I have seen in other threads (or bugs) that this was a general issue with 11. In python, I sometimes get completion for stdlib. I rarely get completion on my own code. I have seen a tooltip probably 3 times. I have not been able to jump to any definitions, I just see a “Could not find definition” popup. I have tried adding paths to the project and globally. I taught a class last week and all of the engineers were using pyCharm and I did not realize how much I have been just dealing with this issue over the last few months until I saw them working.


That sucks you’re having issues. Since this thread was about PHP completions I recommend you start a new thread with specific example code that breaks code intel so we have something to debug. If we determine that it’s going to be fix by this then so be it but at this point we can’t assume they are the same issue.

Apologies again for your frustration.

  • Carey


I have been using Komodo IDE since version 8 or so with my previous employer.
It has always had to-notch Perl debugging support, and that is why we ended up using Komodo IDE.
I even managed to cajole some of my colleaques to use Komodo IDE.

I agree 100% with OP, in addition the code Intelligence feature doesn’t detect anything Perl-related anymore. It used to in version 10 to detect something, but no longer.

I got some time from my employer to improve the IDE support for Perl and we have been very excited about Visual Studio Code, and its open and free ecosystem of plugins.
The problem with VSCode plugins is, that they are still quite far from the Komodo IDE 8 Perl development experience and it would take substantial effort to make them run as smoothly.

Here is my project:
It is not very large and running
perl -c migrate.pl
should run just fine

Tested with Perl 5.22.1 and Perl 5.28.0

Hi, sorry to hear of your troubles with CodeIntel. Do you have something more concrete to share other than a vague “it used to work, but no longer”? Without some more information, we cannot take action.

How can I get more information?

I just installed the 21-day trial and loaded that project in.
Made sure the migrate.pl compiles and shows no warnings.

Steps to reproduce:

Okay, thanks for the detailed instructions. That’s exactly what I was hoping for. I’ll give it a go when I have some time and get back to you.

Okay, I have identified the problem and logged a bug on our tracker: https://github.com/Komodo/KomodoEdit/issues/3582

It will be fixed soon. Sorry for the trouble and thanks for your patience.

I wasn’t quite expecting the problem to be of this magnitude.
Good that you identified it after all.
I’ll retry after the fix has been released.