Komodo 10: unexpected error: TypeError: view.scintilla is undefined

Hello guys,

i don’t know whats wrong wir komodo but there are so many bugs and errors inside that working with this software is hardly possible: My newest error today is:

unexpected error: TypeError: view.scintilla is undefined

I simply want so search and replace something but no chance…come on guys, i have to work and get my results done, instead i constantly have to waste my time with bugs and errors…i’m getting more and more angry about this editor and really think about switching to another software.

Btw: Everything was fine till Komodo 8, maybe i’ll just have to “upgrade” to this version…

Hi, sorry to hear of your troubles. More often than not errors are caused by outdated add-ons. Try restarting in “Safe Mode” (Help > Troubleshooting > Restart in Safe Mode) and see if that clears up the problem. (9 times out of 10 it does.)

Oh, and please send us the full error message in your Help > Troubleshooting > View Log File. Thank you.

In addition to what @mitchell asked - do you have a file open when running that find/replace? I would assume so, but let’s get the obvious out of the way.

I’m able to get the same error when trying to search in current document when there’s no document opened.

Here’s the report:

Change “Where” to Files or project root and you’d be fine.

Hi guys,

thanks @mitchell, @nathanr and @Defman for your tips, i just found out what was causing the issue:

There is an option in “Preferences>Find” calles “Open find results as file tabs”. After i deactivated this option, everything worked fine.

As i’ve seen, Komodo closes my opened file immediately after i hit the “Replace All” button, i think thats the reason.
Maybe that problem is directly related and a following problem which gets fixed as a positive side effect.


Thanks for sharing your findings @petewulf, that’s very helpful.