Komodo 10 indent / dedent of group of lines uses tab i.s.o. spaces


indentation in Komodo Edit 10.1.4 is configured with 2 spaces per indent, width of tab to be 8, ‘Prefer tab’ is enabled as is ‘backspace decreases indentation’. This is true for the global configuration, the Perl settings and the current file preferences.

When indenting a group of lines (in a Perl program in my case) the indentation might be more than 2 spaces, as the spaces at the start of the first line are replaced by a tab character. The other lines are indented with the same amount. When dedenting, the first tab character is removed, thus the dedent is 8 spaces i.s.o. 2. In Komodo Edit 9.3.2, with the same configuration w.r.t. indentation, indent and dedent is always 2 spaces, with a conversion between spaces and tabs as needed. This behaviour in version 10 does look like issue #1744.

Is this a result of wrong configuration?

It doesn’t appear to be a configuration issue. It seems like an expectation issue. When you tell Komodo to use tabs whose width is equivalent of 8 spaces, you need to throw out any expectation of 2-space indentation width, regardless of what your file originally has. When tabs are enabled, Komodo will use them for indent/dedent, and not spaces.

Thanks for your explanation. The conclusion is that Komodo 10 shows the expected behaviour, while Komodo 9 does not. As I like the way Komodo 9 does the job, I think I’ll stick to Komodo 9. Note that both versions behave the same if the tabs are entered following some text on the line.

I recently found the following article: https://community.activestate.com/taxonomy/term/559. As I read it, it states that the behaviour of Komode 10 is not correct.