Komodo 10 freezing during Git info update

Hi, The problem is the following: I had 10-15 files opened in a project under Git control.
I commited the changes and switched to another brunch in SourceTree and came back to Komodo. I was waiting that IDE already refreshed the stage and content of the files but Komodo was absolutelly not responsible. I was looks like the window was covered with white semitransparent layer. All other application and system were working fine and I was able to switch between windows easy. I tried to close Komodo with the standard window [X] icon. This panel is covered by Komodo UI as usual, but appeared in this situation. System offered me to wait for responce or close the application. I clicked “close” and the process was killed. And I got this problem not for the first time. I got this crash about 5-6 times today.

Komodo IDE, version 10.1.1, build 89474, platform win32-x86.
Built on Thu Sep 01 14:27:01 2016.
Win 7x64

Hi @MaxA,

I tried something similar:

  • I opened 26 files that are all under Git
  • Edited and saved them all
  • Went to my command line and performed a git stash
  • Go back to Komodo

Komodo does not hang. I get a dialog asking me to Reload Changed Files and Projects and lists all the open files. I click OK and I’m good to go.

Just to be safe I created a new branch and commited all of those changed files on that branch. When I switched back to master (aka, those files haven’t changed and revert back to their original state) I get the same dialog asking me to reload changed files but Komodo doesn’t hang.

Is this 100% reproducible for you?
Is there anything in the logs when this happens?
Can you reproduce this in Help > Troubleshooting > safe-mode?

  • Carey

No any visual dependecies for me. Always sudden.
Just got it, kill the process and save the log immidiatelly. Attached.
Cannot upload the zip, so the cloud URL.

This is being tracked here:

Is that you? If you have additional information to add there, please do. So far we have narrowed it down to something wrong in the user data directory.

  • Carey

Max is not Anselmo :slight_smile:

100% :grinning: