K10.2 gets _really_ slow after a while

10.2.2 is coming really soon. Nightly builds are usually stable though, so you can give it a try.

10.2.2 specifically addresses this issue, I don’t see how it not being released officially is relevant to us addressing the issue. It will be released soon.

I upgraded yesterday to 10.2.2. Previously Komodo was getting sluggish after 2-3 hours of use - now it gets there within the first 30 minutes. It hogs into one of the CPUs and regular intervals and that dramatically affects file editing.

Please continue to use it for a while, it’s very unlikely that 10.2.2 would cause this. I’m guessing this is correlation, not causation.

Unfortunately the problem is still there - both on my laptop (i5+ssd+8GB RAM) and main desktop (AMD hexcore, 16GB RAM, reg. hdd). From my observations it looks like codeintel is slowing down the GUI (resulting in horrible editing experience). Something is blocking somewhere - and if codeintel is slowed down by anything - be it remote fs or large amount of files or a combination of these - or just a busy disk - then that sets its footprint on GUI reaction time.

Both machines run the same Komodo IDE 10.2.2 - and have different profiles, created at different times and with slightly different settings. SCM integrations are disabled in Komodo in both places.

As it was written by someone before - at some point Komodo Edit and IDE just became mega slow. Could be said codeintel and some pretty well hidden blocking that degrades performance?

Given the nature of codeintel it could also be the size of the projects you are working on. You could limit codeintel’s scope from preferences.

Regardless, this issue will be addressed for Komodo 11. We are largely rewriting codeintel and almost all of it will in the future live in a separate process.

If you’re thinking it already lives in a separate process, that’s partly true. Certain parts do live in a separate process at the moment, but it only amounts to about 50% of codeintel. In fact some of the heaviest stuff (the semi-parsers) are still running under the main process, which definitely contributes to Komodo slowing down.

That explains the problem. Throwing a large project and expecting codeintel to “help” also when it comes to for example vendor directory is a no go if that’s part of the same thread/process.

I assume it should be enough to switch off code scanning in options? I would like to retain some parts of the intel “within the same file variable and function autocomplete” and for example tooltips for PHP functions. Will removing a checkmark from “Include all files and directories from the project base directory” work? Even if I am not working with a project, just scoping via “Make this directory root”?

Or is there a better way to nuke codeintel and just keep the bits I named above (PHP tooltips+within the file variable/function)?

You cannot turn off codeintel, but you can limit its scope. Primarily by:

  • Setting exclude directories (eg. vendor dirs) in Project preferences
  • Setting the max scanning depth in Prefs > Code Intelligence > Code Scanning

11 posts were split to a new topic: Crashing on Linux (pt_PostNotifyToCvar)

I’m not getting them too, btw.

I just wanted to update on this.
Komodo IDE, version 10.2.2, build 89904, platform macosx.
Built on Mon Jun 12 12:21:57 2017.

Is still slowing after about a day of being open. Things that are instant start to take a few ms more. After a week of being open, it’s ‘beachballing’ constantly. I’m talking little things like after keystrokes. If I try to shift-highlight something then it’s going to take 10s or 100s of miliseconds to respond.

of particular issue is deleting or inserting blank lines, the dexy is not redrawn for some time. I don’t know why that would be a code intel thing.

My machine has changed though, I’m now on
MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports)
3.3 GHz Intel Core i7
16 GB 2133 MHz LPDDR3


Please try the test build found in initial comment of this ticket:

Look for the Note From Developer - Please Read section.

That build might help.

  • Carey

My reported build is 89904, which is after the proposed build of 89898. I would assume the fix is in 89904 as well?

I last opened my Komodo about this time on wednesday, and just started beach balling on whitespace changes. It’s even beachballing on mouse clicks, no changes in the editor.

Your build does not include the fix. Try the one linked in the ticket.

  • Carey

Thanks for the clarification. I’m running that explicit build now and will report back in 2 weeks.

@Scorp1us, probably better to report any additional information in an existing bug report. This one seems to be what you’re reporting:

More info would help us.

Thanks for getting in touch with us about this!

  • Carey

I’ll report it where ever you want, but this issue is for 10.2, that one seems to be 10.1.

True enough but it’s like the same issue. We never fixed it so I have no reason to believe that they are different issues. It will be really interesting to see if this test build helps. If it does you can report in that ticket and those users can try it to see if it helped.

  • Carey

Still not fixed.

I googled “komodo slow performance” and got this page.

CPU utilization eventually climbs above 100% when the IDE is sitting idle.

Komodo IDE, version 11.1.0, build 91033, platform macosx.
Built on Wed May 30 10:04:57 2018.

MacBook Pro (2017)
Processor 3.1 GHz Intel Core i7
Memory 16 GB 2133 MHz LPDDR3

Hell, even when it’s freshly open and sitting there with no documents open, it sits at approx 8% utilization.