Js.exe high CPU usage


Related to Komodo X js.exe process eat 30+% of my Intel I5-4670K @4Ggz CPU as permanent BG task.
It sees to me that’s too much.

Regards, Max.

Does disabling linters and restarting Komodo make the CPU usage go away?

Preferences > Syntax & Spell Checking > Uncheck “Enable background syntax checking …”

Don’t know, the problem exested during 3 days, I didn’t write you the post immidiately after appearency but was watching during 3 days to be sure. It’s everything ok now. I didn’t make any config changes. I’ll continue to watch this issue.

My guess of what’s happening is the linter is somehow getting stuck on one of your files. Finding out which file and why it’s getting stuck is the challenge in validating that theory. When this next happens try and see what you did that might have triggered the issue, eg. what files did you open.

Great, Nathan, thanks for the tip! I meet this problem again. I can tell you more, I got freezing Komodo, kill it, start again and that happened many times. Than I found 4 x js32.exe eating 25% of CPU each :slight_smile:

Working ok now without spelling.

What about files, I had the mixed content of HTML, CSS, JS and may be PHP, don’t remember about PHP exactly.

Only linting would invoke js.exe. Could you try enabling linting again and playing with the settings for specifically the JavaScript linters?

Another one hungry process (20%+) is python.exe.

That Python one is likely codeintel as it’s scanning a large set of files.

But it scan it all the time, yes, there are a lot of the is subfolders. What ca we do?
May be I don’t need thas scanning?

Komodo will on occasion use CPU to perform its duties, this is not an issue we are addressing. We are addressing processes that are using an inordinate amount of CPU for a long period of time.

For the record Komodo 11 will feature a largely rewritten CodeIntel, but scanning large directory structures can still be costly of CPU. You can minimise the effects of this by updating your CodeIntel preferences.