JavaScript "if" autocompletes in comment


#1

In a JavaScript line with a “//” comment, if I type “if” as part of my comment the autocompletion fires and I get “(test)” along with braces and a “code” marker. I cannot figure out how to stop this from happening. (I’m a newbie to this forum, so please let me know if I’ve missed something obvious, or if I’ve posted this question in the wrong place.)


#2

@stek, that’s auto-abbreviations or “snippets” firing. You can disable them in Edit menu (Komodo on OSX) > Preferences > Editor > Smart Editing > Auto-Abbreviations.

  • Carey

#3

@careyh, Thanks for the info; I’ve just done as you suggest.

But disabling the irritating “snippets” for “for” and “if” in comments disables all snippets in live code. While that’s an improvement from my point of view, it renders all the work you folks did to implement snippets useless to me (and presumably quite a few other users).

As smart as your smart editing features are, might it be possible, in some future release, to prevent snippets from firing in comments? Is this already in your bug database? And if not, should I report it as a bug?


#4

@stek, I thought you just wanted them turned off. By all means you can file a bug here: https://github.com/komodo/komodoedit/issues/new