Interpret file as a specific encoding

I’ve run into this a few times – some files that are UTF-16, Komodo Edit instead thinks are “Latin-1”, resulting in a NUL-filled mess… and I can’t for the life of me find a way to tell it otherwise. The only options I find are for converting to a different encoding, which is useless if it didn’t read it in the right encoding in the first place. How do I say “no, stop it, this is UTF-16, trust me”?

Could you file a bug for this?