Install perl workspace and debug web application

Hello everyone. Sorry for my English : )
I’m new in Komodo and have some starter-problems.
First of all; here my purposes: I’d like to run – and debug - server side perl programs. I’d like to press a button “run/debug” and get a link for my browser where I can submit forms and step via Komodo through. Komodo/ the perl-dev-kit seems to be perfect. So I’ve downloaded the PDK and installed Komodo.
I’ve an Ubuntu x86_64 GNU/Linux installation.

The first small problem was the PDK. If I have executed the and given the pattern “/pdk” a message says:

Note that the following version of Perl is not compatible with this product:
/usr/bin/perl: - ‘/usr/bin/perl’ (x86_64-linux-gnu-thread-multi) is not binary compatible with ActivePerl (x86_64-linux-thread-multi)

(By the way; I found this command and have installed all: sudo apt-get install libc6-i386 ia32-libs ia32-libs-gtk)

I have bridges this by following steps; in Komodo “Edit->Preferences-> Languages-> Perl-> PDK.” For this two locations I have selected the folder by myself. I hope that’s fine.

I have downloaded an other ActuvePerl here:
Now the install is done.

So – what have I do next?
In “Debug – Go” I have defined “Simulate CGI Environment” and in “Edit-Preferences-Debugger-Connection” I have tested a few combinations. For my current step I uses “a specific port: 9000”.
If I start now my program and select under “Debug Output” HTML, I can see my form. If I set few options and submit it, it will display this error:

You don’t have permission to access / on this server.
Apache/2.2.22 (Ubuntu) Server at localhost Port 80

Note: of curse my program works when I run it via my browser. And the file/ folder has for testing 777 permission.

Is my plan at all possible or do I totally wrong?

Thank you for every help or tutorial link!

Generally, if you want to debug perl web server, you’ll want to use the remote debugging method [1], as that allows you to use your browser to fill in forms (as you do normally without debugging) and then the perl request will be handled (debugged) by Komodo.



thank you for your answer!
To be honest I have these sections already tested several times - on linux and also on windows. = (

If I run my test-script via perl -d it will open just the "normal debug dialogue in the console - and no komodo-popup is raising…
And if I open my script via my browser, there also will nothing happen in komodo.
Same thing with

The depremierende part:
If I configure PHP with xdebug everything goes after a few minutes configuration. For example, in Windows as follows:

Do I have to define in Perl also any GET variable in the call?
Or does it really only works on “perl -d” as described in the section?
Maybe I missed something - I will again read the instructions completely through. =/

Omg finally; it works.
After two weeks I write a summary.
But first; finally holidays : )

Glad you got it working! The instructions are very specific (I’ve botched them before too) and there is little indication on what went wrong… unfortunately that is all in the Apache config settings - so there is little we can do to enhance that side of things.

Sorry, it took a little longer.
The problem was that I did too much.

Only the apache-config part was needed:

Modify the httpd.conf file: The following values can be configured for a specific virtual host or all hosts. Add the following values in the appropriate sections:

SetEnv PERL5LIB "C:\Program Files\ActiveState Komodo x.x\lib\support\dbgp\perllib"
SetEnv PERLDB_OPTS "RemotePort=<hostname>:<port>"
SetEnv DBGP_IDEKEY "<ide_key>"

… and the -d flag. That’s it.

That is not tinkered again, (Proxy Setup etc.) any Komodo installation performed on a dedicated server.
So paralelles work is simple.

As a side note: PDK is not necessary as it seems.