Inline js written to /tmp on save

Using: Komodo Edit, version 10.2.2, build 17703, platform linux-x86_64.
Built on Sat Apr 29 00:10:22 2017.

Recently I have been updating a website of mine.

I have noticed that Komodo upon each save of a html file with inline JavaScript time writes into the /tmp directory a file named “tmpXXXXX.js”. These (varying in size between 14 and 85k) contain lots of empty lines plus my bits of the inline-js.

There may be a legitimate reason for this (thus no bug report), alas these files ought to be deleted at the end of each session (I accumulated close to 10000 over 2 months before I noticed them).

Therefore the question: is there any way of preventing these file being created (in the settings)? [Apart from not using inline-js, which is easy for testing].

One obvious workaround is of course to write a cron job along the lines of
rm /tmp/tmp*.js but this may affect other programmes.

Any better ideas?

You can try disabling syntax checking for JS. I think the JS syntax checking tool may be responsible for creating so many temp files.

This sounds like a bug I reported and subsequently closed because I couldn’t reproduce it any more.

@Adi, have you noticed the errors I mention in this ticket in your logs?

I see you’re on Linux…there goes my Windows theory.

Turning off js syntax checking has no effect.

I am perfectly happy with the workaround running a cron job once a day removing the pattern tmp*.js Therefore as far as I am concerned I’d say problem solved.