Indentation Issues

So, a user for a number of years… this problem seems to be persistent across all komodo versions I worked on, aside from perhaps long time ago when I was using “Komdo Editor Free”.

Upon opening of an existing project on the local drive, the indentation will be re-set to 2 spaces per tab, regardless what is in the settings. Below is a screenshot showing all possible indentation settings being set to 4, yet the initial file on project load showing 2 spaces per indent.

Usually cycling/changing one of the 3 panel’s indentation setting resets it to 4 spaces - ie on the main preferences, set the option to 2 spaces per tab, apply then set the option to 4 spaces and apply. This will finalyl show 4 spaces per tab in the editor.

The problem is persistent, sometimes showing this when a project is opened, sometimes when a saved file from the project is opened.


Start by unchecking Allow file contents to override Tab. That should do it.

thank you kind sir,
after unchecking both in main prefs and in project prefs, the indentation setting of 4 chars seems to persist between komodo restarts.

1 Like

Excellent! Glad to hear it @papachumba.