ImportError: No module named psycopg2

I’m now trying to use the play button to execute my python scripts.

#!/usr/bin/env python2
import sys
import psycopg2

When I run from a command line, it works, when it’s invoked from KomodoIDE it fails.

Hi, please either update your PYTHONPATH from Komodo (Edit > Preferences > Environment) or add the directory “psycopg2” exists in to Edit > Preferences > Languages > Python > Additional Python Import Directories.

So curiously, it’s not using my homebrew install, it’s using Apple’s.

I had it set to ‘Find on Path’, which should be what #!/usr/bin/env should be doing. It’s like komodo isn’t executing the shebang, but rather running it as a python parameter. Is there a way to have KomodoIDE smart and only use it’s invocation when there is no shebang? Shebang should overrule everything else.