IDE. Some missed features for perl


#1

Hello.

Since IDE became free now I’m trying to switch from KomodoEdit 11.0 to KomodoIDE 12.0 and now I’m disappointed. For first look IDE is much slower than Edit and has less features (at least for perl)
Some examples of missed features:

  1. Function arguments tooltop.
    Edit works perfect:

IDE does not:
IDE2

  1. Ctrl + mouse pointer to name:
    Edit:
    edit3
    I could not find the feature in IDE.

  2. Methods tooltips
    Edit:

IDE:

Path::Tiny is not core lib, but is installed in standard system wide directory.
Seems like auto-completion is working only for core libs, I’ve tried with Net::Telnet and it worked.

  1. IDE wants to scan directory with perl libs that I installed with CPAN, there a lot of files. And If I will allow it then code completion becomes so slow that I can speak it does not work.
    Edit asks nothing, it just works.

#2

+1

I also moved to KomodoIDE 12.0 just a few days ago. It’s indeed a lot slower than KomodoEDIT 11. I haven’t noticed any missing features yet but I’ve mostly edited html files so far. What I did notice was that commenting out multiple lines at the same time now creates a block comment spanning all lines rather than making a separate comment for each line. For me this is less practical since I frequently comment out an in different blocks and now I have to comment out each block separately to be able to uncomment them independently later. Maybe there’s a configure option for this.


#3

Hey everyone (including anyone who comes across this thread). Please do not use this thread as a dumping ground for one off issues that you have. Start a new thread if you’re having an issue.

@JesperIRL, Please open a new thread to see what’s going on with block comments for you.

@Alexander_Zaitsev, we can use this thread to try and figure out why Perl code intel isn’t working as your expect. Can you please update the thread title to be more specific towards the issue you’re experiencing?

  • Carey