How to use "Format" option?

How to use Format option? (Available if press RMB - Format).
Seems like it’s must show me new menu (Like Refactoring) but not :frowning:

Might be a bug (is it Komodo IDE 9), as it should show you the different formatting handlers (like HTML tidy, or JSBeautify).

Check your “prefs.xml” file in your Komodo profile folder, see if there is a “configuredFormatters” entry.

There is empty XML list:
<ordered-preference id="configuredFormatters"> </ordered-preference>
Yep, it is Komodo IDE9.

A bug then, I guess you’ve added a custom formatter (and it’s failed, leaving you with no formatters). I’ve logged this bug here:

To fix, just delete that preferences (i.e. those two lines) and you should be back to the default formatters.

1 Like

Nope I’m not.

Okay, I’m try this, thanks :wink:
Yep, after removing these lines all works fine :smile: