How to turn off autocomplete

I’m using Ver 12 and find the autocomplete quite annoying. I’m coding in Perl. When I type print it furnishes LIST. If I don’t backspace to delete the suggestion and go on typing starting with a quote (which I do 90% of the time for print statements) it puts quotes around LIST and I have to backspace to delete the whole mess.

I’m not sure I’m calling it the right thing. I have uncheked “enable completions” under code intelligence preferences and it doesn’t help.

@DryHeat122 the wrapping of the quotes is a different setting:

1 Like

@DryHeat122,

You’re also getting hitting Auto-Abbreviations: Prefs > Smart editing > Auto-Abbreviations. You can either disable them or edit the abbreviation in your toolbox:

  1. Find the abbrev. in the toolbox, View menu > Tabs & Sidebars > Toolbox: Abbreviations > Perl. Looks like you’re hitting Keywords > print
  2. Right click > Properties
  3. Experiment (Snippets/Abbreviations support EJS segments so they are very powerful).
  • Carey

Thanks. These things were driving me nuts.

1 Like