How to switch off expansion of trigger word "hash"

Hi all, I’m using Komodo IDE to edit Perl code. Each time I write the word “hash” in a comment (or elsewhere) Komodo IDE expands it to
%name = (
=> ,
=> ,
which is really annoying. At the moment I solve this by typing an additional character after the word “hash”, which is not a whitespace - e.g. “hashj”, then mark this character and overwrite it with a space, but I find this very cumbersome.
I would rather like to switch off this auto-expansion. Does anyone know, how to do this?
Thanks! Gerhard

@gpetrowitsch, you’re looking for
Disabling snippets / auto-complete completely?

Yes, that’s it. However, the option is everything else but self-explanatory. It says “Enable Auto-Abbreviations with Trigger Characters” and then there’s a long list of special characters. How can I know from this that typing the word “hash” - where there is no such character involved - has something to do with this option?

Anyway - this solves my problem. Thanks a lot!

@gpetrowitsch, I’m not sure if you’re giving feedback or if you’re trying to explain why you didn’t solve it yourself? If it’s the former, that’s great. I think it might be more obvious if the feature had been called Auto-Snippets as I think at this point, across different editors, that’s the agreed upon term.

If it’s the latter, don’t sweat it. Apologies if I was terse, I didn’t mean to sound rude. Just giving you what you need as quick as I can :slight_smile:

@careyh I’m sorry for the confusion. You didn’t sound rude at all. I just wanted to thank you for helping me finding the right option and explain, why I didn’t find it myself.

In fact, I already had the right dialog open, but could “connect” the title and appearance of the option (especially those special characters were confusing) to my problem.


1 Like

@gpetrowitsch, excellent! Glad we could get you sorted out!