How to spontaneously open code intelligence in a Tcl script

Hello all,

I tried to write Tcl scripts in komodo IDE, but I found that code completion only appeared when I wrote tcl commands on the first line, and no code completion appeared on other lines. I also couldn’t find a shortcut to actively trigger code completion.
But in scripts other than tcl scripts, such as python scripts, code intelligence work fine, but they still can’t be triggered actively. I tried all the shortcuts in the key bindings that have “CodeIntel”, but they didn’t work at all.
I wanted to make code hints work in tcl scripts or find ways to initiate code intelligence.

This is the demo that can trigger the code intelligence, now I write the script on the first line

  • But on other lines, I couldn’t trigger code intelligence

I am able to reproduce this but I can’t say what it might be. I do note that if I shift line 1 down and type above that code intel starts to work again.

Things that come to mind:

  • Possible syntax error in the code starting at line 1 which breaks code intel below that point. I know nothing about Tcl so I can’t reliably test that

  • Something specific about the sample code provided that is breaking code intel

    • Try other code samples to see if code intel works again then narrow it down to what’s breaking it in the current code sample
  • The code intel is just broken

    • You’ll need to dig through the code intel code to try and get this sorted. I can give guidance there.
  • Carey

Thank you for your reply.

I’ve tested it against other scripts as well. All of them are fine, and only the tcl script has this problem. I can guarantee that there are no syntax errors in my code.

And I found it interesting that I couldn’t trigger code hints in komodo IDE, but I could trigger code hints in komodo Editor - the pure editor version - and I compared their Settings and there was almost no difference.

I don’t understand how code intelligence works, maybe I need to delete some configuration files or cache files and reinstall them? What configuration files or cache files do I need to delete?


Komodo Edit and Komodo IDE have completely different Code Intel systems so 1 working over the other doesn’t mean much here, other than maybe you should use Komodo Edit? Code Intel was re-written in IDE for version 11 I believe. You could close Komodo and delete any codeintel3* files from you profile folder: Important File Locations - How To / Tutorials - Komodo IDE & Edit | Forums

I’m only talking about Tcl.