How to prevent Komodo codeintel from scanning certain directories?


#1

Hello,

I’m working with KomodoIde and I have a Project.
The project is Symfony2 based, so you can imagine there are a lot of files.
Scanning for the codeintel DB takes too long - I’m on Ubuntu with i7 and it takes a whole minute for the scan to finish.
I get also this message:
“This buffer is configured with 947 PHP import dirs: this may result in poor completion performance”
I don’t care for the core Symfony2 files and bundles, I just want to have autocompletion for my own code only.
I tried Project->Properties (suggested from other thread) and added there only the folders I want to be scanned, but it keeps scanning the core Symfony2.
I tried with stopping Komodo, removing codeintel folder and starting Komodo. The same.

Is there a way to exclude certain folders from the codeintel scanning?
Or to specifies only the folders I need to be scanned?
The IDE is hardly usable without such a feature in Symfony2 based project!


#2

Hi @nikolay_ivanov,

This has been requested before. I’ve moved the ticket to Github issues, where we are tracking requests and bugs now; issue #195.

For now you can try Edit menu > Preferences > Code Intelligence > Code Scanning: set the max directory scanning depth

  • Carey

#3

Thanks, I’m using this already.


#4

@nikolay_ivanov, is the code intel feature not working for you at all? Or is it that the first scan took a minutes to complete?

The former is bad obviously. The latter is normal in large code bases. That should only occur with the first scan. After that code intel uses the existing code intel database without needing to rescan.

  • Carey

#5

Ever since I upgraded to the latest Komodo edit, I have the same problem. I used to love this product but it’s becoming highly annoying. It’s not just at the opening of a document, it’s even while editing the product sometimes just… freezes, looking up a custom function in a directory it won’t be able to reach or something. I want this feature out! I find myself switching to gedit ever more often :frowning:


#6

@Randy_Gerritse You want code intel removed? You can disable some Code Intel features in Edit > Preferences > Code Intel or you can totally disable it from Tools > Add-ons (legacy.

Also could you confirm which version you’re using Help (Komodo menu on OSX) > About Komodo? Quite a few performance enhancements went into the latest “nightly” release. I’d like to know if they are having negative effects in the wild.