How to enable autocomplete for added packages (OpenCV) - OS X?

I’m coding in Python 2.7 using Komodo 8.5 on OS X v10.9. I’m a novice Komodo user.

I’ve added OpenCV using brew. It was installed here: /usr/local/Cellar

In my code I have:

import cv2

When I type “cv2.” autocomplete gives me no options. The import and OpenCV code work fine otherwise.

Here’s from the Help/Log:

[2014-12-30 06:20:37,082] [ERROR] koCodeIntel: error evaluating completions:
  trigger: <Trigger 'python-complete-object-members' at 318>
    INFO: eval 'cv2' at  <Trigger 'python-complete-object-members' at 318>
    INFO: start scope is (<blob 'findsquare'>, [])
    INFO: find 'cv2 ...' starting at (<blob 'findsquare'>, []):
    DEBUG: 'cv2 ...' from <import numpy as np>?
    DEBUG: 'cv2 ...' from <import argparse>?
    DEBUG: 'cv2 ...' from <import cv2>?
    INFO: is blob 'cv2' from <Python curdirlib>? no
    INFO: is blob 'cv2' from <Python extradirslib>? no
    INFO: is blob 'cv2' from <Python envlib>? no
    INFO: is blob 'cv2' from <Python cataloglib: >? no
    INFO: is blob 'cv2' from <python-2.7 stdlib>? no
    ERROR: evaluating 'cv2' at could not find data for Python blob 'cv2'

How do I tell Komodo about OpenCV? What file(s) is it looking for and where?
I have other packages I’ve added I’d also like to enable.

Thank you.

You should be able to add this directory using Prefs > Languages > Python > Additional Python Import Directories, if you use projects then you should use Project > Project Preferences instead.

Thanks, Nathan.

Unfortunately, I’ve tried that with no change in behavior.

The opencv subdir contains all h and hpp files. However, there’s a lib/python2.7/site-packages subdir that contains a file. I also have that path in the settings you suggested but no change in behavior.

Do you know what specific types of files the Komodo autocomplete engine is looking for?

Komodo does not yet provide completions for binary Python modules - as it’s only possible to see the contents from instantiation (actually importing the module - which we try to avoid as importing could do something dangerous).

There is a Komodo feature request covering this: