How to configure help?

I am travelling and needed to write some code to manipulate some data so I downloaded komodo 10 to my laptop ( I am on 8.something normally but haven’t done any coding for a long time ) but I can’t launch help for languages from komodo anymore - I have to go into the Perl installation and find the help index.html. to the local installation. My laptop is running win 10 and default browser is internet explorer 11.

How do you try to access the Help for languages
Did you use the menu Help > Help for languages > …?

I tried the perl references, but this is working for me (Win 10, default browser FF).

Thanks - yes in the cold light of day and copying the link to another browser I can see there is a link “table of contents” right at the top of the page that help for languages points to which is and I had not spotted this before. I am used to immediately seeing the pages I now see at when I go to help. I always thought it was the local copy that opened.

Sorry I bothered everyone.

I have the same issue and cannot get the preferences to “stick” for Perl Language Help. Choosing the Perl Reference from the menu lands on 404 page docs.activestate/404.html. Presently I’m using Strawberry Perl on Windows 10.

Hi @wblake,

My guess is that Komodo is processing output specific to ActivePerl to generate the URL that it opens. I doubt Strawberry Perl will work in this context though it should work for everything else in Komodo, ie. writing code, debugging, code intel, etc.

  • Carey

Hi Carey,
Strawberry seems fine for now. On selecting Menu/Perl Reference, the resulting ActiveState page always fails. Setting the Preferences for Language Help does not seem to matter.
Thanks again,
Wil Blake


@wblake are you pressing Shift + f1 and/or ctrl + f1?

(Hamburger)Menu, Perl Reference goes to the 404 page. Ctl-F1 lands on perldoc as described.

OK so my original answer still stands. The URL from the menu is likely being generated from Perl output which is unique to ActivePerl. Komodo can’t generate the correct URL with Strawberry Perl it looks like.

Thanks. I will attempt to install ActivePerl in Windows 10 using my ActiveState Project.