How to clear default of syntax error check on debug

I’ve accidentally marked “No” + “Don’t ask me again” on the debug dialog which prompted for error in code.
Now, I can’t debug with these errors (not real errors, can proceed with them).

How can I clear this default setting? want to be asked each time again.
couldn’t find anything in the settings.

Thanks in advance

Could you please clarify what prompt you are talking about?

When you try to debug code with syntax errors:

Ahh thanks Defman.

I can’t seem to find a pref for it in the prefs window. You could reset the pref via a macro though:

1 Like

The notification in red in the screenshot.

I accidentally pressed “No” with “Don’t ask me again” checked.

How can I revent it?

Create a macro with this code:


And run it once

Where can I add macro code in Komodo Linux IDE ?
All I have is an option to record macro.

Open Right Pane, choose and click right mouse button on the pane, then choose Add - New Macro...

1 Like

Do I need any Python related stuff installed?

get the following error

It is a JavaScript macro :wink:

If so, how about that error?? :wink:

Ahh… your komodo version is 8.5…

is it that bad…?

Try that:


didn’t solve the problem



What returns this macro?

False, no other comments

It might be set on the current file you’re working with, try:


And just to cover all our bases:


That should definitely clear the pref.

returns an error:


TypeError: ko.projects.manager.currentProject is null

exception[fileName] = New_Macro1.js
exception[lineNumber] = 3
exception[columnNumber] = 0

First command was successful, but didn’t solve the issue.

Because you haven’t any projects opened.