How to avoid this automatic input?

Sincerely, there are some Komodo features i don’t understand yet, like auto-abbreviations or auto-completions.

My main problem is writting HTML comments, i want to write:
<!-- this -->
but when i write the first dash ("-"), the text turns into this:

I disabled auto-abbreviations temporary and deleted dash on the trigger characters input in preferences, but it doesn’t fix the problem.

Can you please tell me how to avoid this completion? what is auto-abbreviation?

thank you!

Try disabling Prefs > Code Intelligence > Enable autocomplete fill-up characters

it works successfully, thank you!

@stramin, Auto-abbreviations are snippets that triggered based on a string. The built in snippets and auto-abbreviations are meant as a guide for users to customize the tool to what bests suits them.

It’s an extremely useful tool when you want it and it’s working how you expect it to.

  • Carey
1 Like

Thank careyh, So, they are just what I thinked they are, sadly I tried using them many times, they don’t work for me.

I tried this:

I added 3 snippet as Auto-abbreviations:

  • $lang->tran([[%s]])
  • $cnx->real_escape_string([[%w]]);
  • this_is_a_test

When i write $lang- or $cnx-, nothing happen, probably its because the issue reported above.

I tried writting “this_is_a_test”, nothing happened either…

[Prefs > Editor Enable Auto-Abreviation] is enabled.

What am I doing wrong?

Should I ask this in a different topic?

The auto abbreviations are triggered based on the name of the snippet (not the contents) and currently I believe it only triggers on alphanumeric prefixes.

Ok, I made some changes.

I renamed my snippet as “atest”, the content is “this_is_a_test”

I wrote “atest” in my code, and… it didn’t work :frowning:

Where did you save the snippet? The folder structure needs to match the language you’re using it in. If you want it to trigger anywhere you could save it in Abbreviations/General, if you want it to trigger only for PHP you’d save it in Abbreviations/PHP, etc.

1 Like

More details on what @nathanr said:

Note the The Two-Minute Abbreviation Refresher Course section.

  • Carey
1 Like

It works! thank you!

  • As Nathan said, the snippets should be in the Abbreviations folder.
  • As Carey showed in his link, I must write a “trigger character” (like *)
1 Like

Team work!

1 Like

Note the trigger characters are configurable under Prefs > Editor > Smart Editing > Auto-Abbreviations

1 Like