How to add TCL variables to the watch list

I’ve downloaded the trial version of the IDE in hopes that I could use it to step through my TCL code and watch variables. These features don’t seem to work for me. Is there addtional configuration requred to add variables to the watch list or to step through the code one line at a time?

Please have a look at the documentation for Debugging Tcl.

Basically you’ll first want the debugger to stop at a breakpoint, after that you can go through your code line by line, if that’s what you wish.

Thanks for the information, but I got lost right away. The second instruction is to login to the remote machine, but there is no remote machine. I am installed an running on a local machine. The third step says to open a command window and run the command: dbgp_tcldebug, but this is an unknown command. Perhpas there is a path setting someplace?

Question: If the IDE settings are set for TCL should I expect for it to step through the code out-of-the-box? I have an option to “watch a variable” but nothing happens when I select that option. I can successfully run the code if I “run without debugging.” But, the IDE is silent when I try to do anything in the debug menu.

“Remote Debugging” is a section, not a step. If it does not apply to you - don’t use it :wink:

Please read the Configuring Local Tcl Debugging and Invoking the Tcl Debugger Application sections.

Generally you should be able to debug Tcl with Komodo out-of-box, provided you have a Tcl interpreter installed (separate from Komodo) and configured Komodo to use that interpreter.

That said, I’m sure there are some edge cases - what type of Tcl application are you debugging?

BTW, you can try the sample tcl file (included with Komodo) for simple debugging - use the View > Start Page and then click on the Sample Project link, then open the tcl_sample.tcl file and use Debug > Go/Continue to launch it. You can put breakpoints as you want.


Thanks for your help. I am convinced now that the IDE is just not working. I am familiar with using an IDE and what I am trying to do is quite simple. I installed the IDE, I typed in 5 simple lines of TCL code with a foreach loop to test the IDE’s debugging features.

The IDE can run the 5 lines of code with no problem which tells me it can find the interpreter, however any commands associated with stepping through the code, watching variables, or breakpoints have no response. I’ve put in a call to ActiveState to see if someone there can help. I talked to a guy, but he said he’d call me back. So I will try to wait to hear back from them.

The only other thing I could think of this that may be the IDE doesn’t work unless is installed with an ActiveState distribution of the Tcl interpreter? I would not think this is the case since the docs say you can simply point to your interpreter and since the code runs as long as I am not attempting to use one of the debug features.

What OS and Tcl versions are you using? Also, can you verify your settings in Prefs > Tcl > Debugging and try enabling Logging to see if that gives you any useful information.