How do I force all files to be utf-8?

I keep having problems working on a Mac. It saves files by default in “Western European (Mac roman)”, which includes odd quote characters and such. Node.js doesn’t like that, and it is really a pain to remember to change the encoding on every file. I can’t find anything in the preferences that would force a particular encoding. I would prefer all files to be utf-8 or plain ASCII.


1 Like

Have a look at Preferences > Internationalization, you can handle your default encoding settings there.

Note there is no way to brute-force an encoding aside from writing a macro for it. These settings only change what encoding to use for new files, it would be potentially destructive to override existing encoding on files.

Perfect! That was what I needed.

Hey nathanr. I really really thank you for helping. that was what I needed. love u guy

Happy to help :slight_smile: