How do I enable Source Code Control in Komodo 10?

I’m a long time Komodo user, recently switching to 10.0 and Source Code Control is not working. All menu items in the “Source Code Control” context menu are disabled. I’ve filled out the Perforce section of Preferences=>Source Code Control. Is there a new on/off switch somewhere? When I try to save a file after making changes I get a dialog that says the file is ready only and only offers to Force-Save, Cancel, and Save-As


It sounds as if something is wrong with your setup. Does the same perforce repository work with Komodo 9?

Note Komodo 10 VCS works best if you point Komodo to the source directory of your repository.

I agree - I switched a project from 8.5 to 9, and SCC (git specifically) is just working. Empty SCC menus sometimes, I can’t run an update, etc. So far I’m having quite a bit of trouble getting 10 to be useable.

I appreciate your frustration, but for us to look into this we’ll need to know more than that you are having trouble. Please be descriptive with your issues.

I just got the 10.0.1 update and it did fix some other issues so hopefully it will fix this one as well. Basically I have a remote GIT repo that I cloned via the command line within a Komodo project. When the remote repo was changed in Komodo 8.5 I could “update” via the context menu’s SCC submenu in the left sidebar. When I switched to Komodo 10 it looks like it is no longer able to see the remote GIT repo. I can still check in locally but no option to push or do an update.

Hi Nathan,

I have been using Komodo 8.5 and never installed 9. SCC still works in 8.5 I use Perforce and the only settings for this in Komodo are the path to the executable and other minor details. I figure Komodo just issues shell commands, like "p4 edit ", so it wouldn’t need me to provide details about the repository. I’m not sure what other details about the problem I could provide.


Is Komodo pointing at the root of your repository? If not, where is it pointed relative to the root of your repository?

That’s true, Komodo just issues shell commands essentially. Though there were some changes in Komodo 10 to make Komodo more “project aware” that we may be seeing some fallout from.

I’d ask you the same question as above: Is Komodo pointing at the root of your repository? If not, where is it pointed relative to the root of your repository?

How does one point Komodo at the root of their repository?

Here’s an interesting line from the Perforce section of the online manual:

“Check out files: Komodo does not have integrated SCC checkout functions. As necessary, run p4 from the command line (e.g. ‘p4 sync path’).”

Every version of Komodo I’ve used, starting with 3.0, has been able to handle opening files for edit.

Thanks for helping. I’m not sure what you mean about “pointing at the root of my repository”. I have a Komoproject, and within that directory, I did a git clone via the command line. The root of what the left pane is showing is one the same level I cloned at (so it contains the entire cloned repo in a sub directory).

This is how I have used 8.5 and it worked great (intact this project was created in 8.5 and I just opened it in 10).

I think you’re confused, the checkout dialog is explicitly for checking out a “new” checkout of a repository. It is not used for simply pointing Komodo at a repository. For pointing Komodo at a repository simply Open a project in its directory or use the Cog icon in your Places pane (select “Open Directory”).

Could you try simply closing your Project (Project > Close Project) and opening it again? This would force Komodo to refresh the SCC status for your project.

Hi Nathan,

Closing and re-opening the project fixed the problem.


I’m still having the same problem…

jellisii@localhost:~/code/foo$ git status
    On branch REDACTED
    no changes added to commit (use "git add" and/or "git commit -a")

Yet when I’m in ~/code/foo, The SCC still doesn’t sort out that the folder is a git repo. The log file gives no indication that anything is happening when I click the offered “Retry” button in the bottom pane. I’ve tried creating/recreating the project within Komodo and haven’t made any traction.

– Edit: Make git output more readable

Do you have git configured (and enabled) under Prefs > Source Code Control > Git.

And you pointed your “Places widget” at ~/code/foo ?

Yes to both.

Wait, I’m an idiot. I did NOT have it enabled. Thanks for pointing that out. :slight_smile: