How do I check spelling?

Komodo 9.2.0 Linux. Searching built in help found nothing (which is strange as “spell checking” is listed in “what’s new”). In a file named “CHANGELOG” the option “Enable background spell checking…” is checked in both general and file-specific options (dictionary=en-us) but I see no evidence of spell checking. I could not find a spell checking item in the menus. Assigning a keyboard shortcut to “Check Spelling” doesn’t seem to do anything.

Help appreciated, thanks.

Spell Checker works in background.

Thanks, but I’m not sure how that helps. As I said, I see no evidence of spell checking. Where are the results supposed to be? Highlighted, underlined, a separate window, pane?

Are you using Komodo Edit or Komodo IDE? The new spell check functionality is only available in IDE.

He’s using IDE as he can see Enable background spell checking... option in Preferences. Or this option available in both versions but works differently? (IIRC in Edit version Spell Checker is an external tool available under Tools menu)


It’s IDE. Here’s my screenshot.

Your screenshot helped me figure it out. The underlining is black! Kind of hard to see with a black background. Fixed it in Preferences/Color Scheme/Indicators/Spelling errors:


P.S. I didn’t seem to find anything on in-line spell checking in the online help or even searching the web, which is kind of strange for a feature bulleted in the 9.2 “what’s new” section. It helps to know how it’s supposed to work.

1 Like

The devs are working on a new documentation site :smiley:

We’ve seen issues with some users’ themes not being properly upgraded with the new spelling error markers. I personally cannot reproduce it, but others (like you) have experienced it. Thanks for taking the time to look into this and report your solution. It will be helpful for others who are upgrading to 9.2.

Thank you! So that’s why spellcheck disappeared when I upgraded a year ago. You made my day!