How can I install new-source-tree add on?

I’m using Komodo Edit 10 on Windows, and would like to install this addon:

Addons are usually installed by clicking on “Go To Anything” and then selecting “Addons”. However, this addon is not in the list. What is then the correct way to install it?

Not quite sure …

The classical way to install addons was:

  • Download the XPI-File to your local disc
  • Open Komodo
  • From Komodo use “Open File…” and select the XPI-File

-> Komodo installs the XPI - you have to restart Komodo to activate …

@rovf this addon doesn’t have a release, so it does not have a .xpi file.
To install this addon, you need to download the source from here

Then you need to unpack the zip file, select all the files in the folder and zip it, rename it so it has the .xpi extension. If you than drag and drop the xpi file in to Komodo the addon will be installed.

I built it for you.

That’s the wrong way of building addons. You should use koext unless you’re sure that the source code will be the same as the result of koext build.

Thank you so much!

I downloaded and installed it. Kodomo Edit asked for a restart, which I did. I could verify that (using the “Tools/AddOns”) that NST is installed and enabled.

But how do I actually invoke it? I had expected either a pane showing a list of the functions in my program, or something similar which I could enable via the View- or the Tools-Menu. But the new addon doesn’t seem to do anything. There is no “source tree” anywhere to see.

It should be in the right pane of Komodo.

In the right, I have the Minimap.

I have now unchecked the box in View/ShowMinimap, but then there is simply no right pane :frowning:

View - Tabs and Sidebars. It should be there unless the add-on is broken.

On “Tabs and Sidebars”, I only see the following entries:

Open Files
HTML Entities
Command Output
Syntax Checking Status

That’s it…

the Source thing.

Aaaaaahhhhh, that’s it. I wouldn’t have it expected under this name. Thanks a lot, now it works!

Can you build this for v11?

1 Like

thanks @Defman!! I try to install it but I get a “installation of addon failed, try installing manually?”