How can I deselect "match whole words" in Find


#1

Komodo Edit, version 11.1.1, build 18206, platform win32-x86 :

When I use “Edit/Find…”, there is a small button which can turn on “select whole word”:

Once it is clicked (i.e. whole words enabled), how can I disable it? Clicking on it again does not change its state (i.e. it does not act as a toggle). I can do a new “Edit/Find…”, which restores “select whole word” to “disable”, but this also clears the search field.


#2

Morning @rovf,

I’m not able to reproduce this. Is it perhaps that the visual cue that the option has become disabled isn’t clear enough? Does the search proceed with “Match whole word” enabled when you expect it to be disabled?

  • Carey

#3

Indeed, its partly due to bad visibility, but I think there is a bug in styling the button too. Switching the User Interface theme from “Isotope” to “Tomorrow_Light” solved the problem. The problem here is: When you first invoke “Find”, ‘match whole words’ is not selected. Clicking on the button to turn on “match word” draws a tiny rectangle around the button, and using “Tomorrow_Light” also turns the text inside the button to light grey. Clicking it again, turns the text inside the button back to black, and we can see that it is deselected; however the small rectangle is not removed. Hence, when using a thema which does not change the inside appearance of the button, we can not see whether the button is selected or not.


#4

@rovf,

Please file a bug report:

Thanks for following up.

  • Carey

#6

Done: Issue #3816


#7

Thanks @rovf