Help with Chrome JS debugging


#1

I just downloaded Komod, first time i am using any editor or doing cs things. When running my code I get a pop up window with “nohtml interpreter is available”. and the help link does lead to a faulty page. Pelase advice how I can run/debug my program. Also, at one point KOmodo stated I dont have chrome, but yes, I do. Thanks!


Message when starting komodo
#2

@tina14f, it sounds like you might benefit from looking at our docs:
http://docs.activestate.com/komodo/11/manual/debugchrome.html

Please follow the instructions there then let us know if you have further issues.

  • Carey

#3

Hi Carey,
I have already done that… when I select preferences/languages/javascript I receive a message in red ""Chrome was not found on your system. If you would like to debug remote web pages in Komodo, you will need to install Google Chrome” - but I already have it installed… . And when I try to select Chrome as my browser in preferences, from the drop down menu , I still receive the same message


#4

@tina14f, I just realized you attached your question to an unrelated forum post. I’ve moved your question to a new post. Please start new topics when you have new question.

Chrome must not have been installed on to your system path. You’ll have to click the Browse… button and select the chrome.exe (or what ever the binary is called on your computer, not sure if you’re on Windows, Linux or OSX).


#5

Ok, sorry for that. Didnt realize… I am on a Mac 10.12.6. I do view it clicki the “eye” icon… but when I run it with debuggin (or w/o dbugging) by pressing the play button on the top tool bar, I still get the message “No HTML interpreter available”…


#6

@tina14f, can you share a screenshot of your Languages > JS prefs? The issue must be there. It’s working for myself.

Also, could confirm the file type you’re trying to debug? I’m assuming it’s HTML but want to confirm.


#7

And yes, it is HTML. I have a couple of lines with a squiggly line… guess the debugger will tell me what to do?


#8

Please note that I do have chrome on my mac, set as default browser too…


#9

@tina14f, you still have to tell Komodo that. When you install an application on Mac, it does not add it to your system path.

As previously mentioned, you need to click Browse… and find the chrome binary. Looks like you can find that at /Applications/Google Chrome/Content/MacOS/Google Chrome

  • Carey

#10

Carey, where do I find the Browse you mention… ? Thanks!


#11

@tina14f, it’s in your screenshot beside the error you’re getting :wink: