Help on mapped uris

Hello to all,
I need a hint regarding mapped uris from different servers.

I do remote debugging on different servers by use of a forwarded port 9000, like so:

ssh -R 9000:localhost:9000 name@server1

To open a file that’s started I created an URI mapping:

file:// => sftp://<ip-addr of server1>:16319/

This works well so far.

The Problem:
I have some other servers to debug (let’s call them server 2 and server 3
and I have no clue how to deal with this different servers.
When I start a script on server 2 (e.g. phpifo.php) Komodo tries to open that file on server1 due to the URI-Mapping.
So every time I change the server I have do adjust the URI mapping which is pretty of annyoing for my workflow.

Is there some shortcut to quickly switch the URI mapping or is there another way to solve that problem?

I am using PHP 5.6 on the webservers and PHP 7.2 on my development machine. All machines are running Ubuntu 18.04.

The only thing I can think of, is creating a new project for each different mapping.
Than you can switch between the projects(mappings).

Thanks, babobski. That’s next to perfect. I didn’t know, that the mapping is project dependent. I’ll give it a try.
Ah, now I understand. There’s an URI mapping in the project prefefrences, too. Never seen this before :slight_smile:. I guess, I have to remove the global URI mapping then. Is that right?

Can I mark this question as “solved” somehow?

You don’t need to remove the global mapping in the preferences.
The project preferences will override the global preferences (and for file specific preferences this will override project preferences).

Only support questions can be marked as solved.

I’ve moved the topic to Support and marked @babobski’s answer as the solution.