FTPS / TLC implicit connection?


I’m trying to use Komodo IDE 8.5 on windows 7 to connect to a remote FTP server that requires an FTPS / TLS implicit connection. Is it possible to connect to this FTP server with Komodo IDE 8.5? I have successfully connected using FileZilla and some other FTP clients, but I would like to connect with Komodo IDE if possible.

Many FTP clients have the option to choose an FTPS implicit connection and it usually defaults to using port 990. I’ve tried specifying port 990 in the Komodo server configuration, but I’ve been unable to establish a connection. I also have my connection configured for passive mode, which is the same in FileZilla. I turned on FTPS logging and here are the results from the log:

[2014-06-13 09:19:09,128] [DEBUG] koFTPSConnection: open: s:ftp.publishpath.com p:990 u:
[2014-06-13 09:19:39,325] [ERROR] koFTPSConnection: FTPS do_openSocket ERROR: timed out
[2014-06-13 09:19:39,328] [DEBUG] koFTPSConnection: del: koFTP deleted

To avoid any confusion, I did use my actual FTP username when attempting to connect, but I did not want to include it above. I’ve tried extending the timeout from 30 seconds to 60 seconds and I also tried not specifying port 990 causing it to default to 21. Any changes I make result in the same timeout error.



This FTPS setup should also work within Komodo. Which OS are you running?

I am running windows 7 SP1.