Font issues with Komodo 12.01 on macOS


#1
  • macOS 10.14.6 Mojave
  • Komodo 12.01

I’m having a strange issue whereby every occurrence of “fi” is replaced by a symbol. See the way Notification is displayed here.

Does anyone know what the problem is here?


#2

Morning @carlcaulkett,

That is definitely interesting. My best guess is that you enabled a font that supports ligatures which “fi” can be.

  • Carey

#3

I tried changing the font used by Komodo for that part of the App, but it didn’t seem to work. I used Tools -> Color Scheme Editor -> Interface, but I didn’t know which element of the list would apply. Any clues?

Should point out that I haven’t made any configuration changes to Komodo since first installing it.


#4

@carlcaulkett, that’s not the default font of Komodo so something is changing it, perhaps an OS setting?

You could also try Help menu > Troubleshooting > Restart in Safe-Mode

  • Carey

#5

That fixed it temporarily. I then tried Help -> Troubleshooting -> Reset Everything, chose a decent color scheme and everything seems to be okay now. It does flash up something briefly about the State Tool not being Installed. But that vanishes after a second or two, and I get the reassuring “Go to Anything” prompt!

Thanks for the help Carey!
Cheers,
Carl


#6

Excellent. Komodo likely imported a previous profile. If there is stuff you want to recover from you previous profile you can find it at ~/Library/Application Support/ KomodoIDE/. Things you might want to recover from the applicable version folder there is any of the following:

  • Tools
  • XRE/[Extentions | key3.db, logins.json]
  • folder-templates
  • schemes
  • samples
  • publishing

If some of those files/folders don’t exist then you must not have used that feature and don’t need to migrate it

  • Carey

#7

I think you are likely right. I may have installed a trial version 2 or 3 years ago and then not bothered with it. Thanks for making the latest version free :grinning: