Fix indentation issue in perl

I’m using Komodo Edit 9.3.2 build 16460, win32-x86. I’ve set my preferences “Prefer tabs over spaces” is turned off, so that a tab = 4 spaces, 4 space for indent, and to prefer spaces to tabs, but Komodo isn’t honoring any of them, neither when I hit enter and the autoindent happens, nor when I press the tab key to change the indent, nor when i use the indent and dedent commands.

I’ve set both the global preferences and the file preferences. Am I barking up the wrong tree, or running into a bug?

This is a bug in the current version, you can download our latest nightly to fix this: