Find in files doesn't appaer to look into "Tests" directories

It appears that “Find in files” (the one that appears on the bottom) is not recursing into directories names Tests. Maybe I’m just doing something wrong, but I don’t see any option that would cause this to happen.

I had random searches that didn’t produce results, despite there being matches. Upon investigation it seems it just doesn’t look into certain directories.

This is a git repository, but these directories are not marked in any way (they’re special to our build scripts only).

I’ve removed the Filter as well and it still doesn’t search in those folders.

It instead appears to only be looking 2-levels deep, since if I search from a folder higher it doesn’t find any of my source files at all, not just the Tests ones. The Tests folder just happens to be a deeper folder than usual.

Is this an option somewhere to restrict search depth?

The search depth will be far more than 2, it sounds like that’s correlation - not causation.

Are you sure you don’t have the folder in your Project excludes?

Is the folder in question under a symlink by any chance?

I have no project file (not a Komodo project, nor a Komodo recognized one that is).

These are not symlinked directories. The main directory is ssh mounted (but I’m guessing Komodo doesn’t care about that).

It shouldn’t care, but it’s possible that the ssh filesystem you use is throwing Komodo off. Could you reproduce the issue on a local partition?

The same problem happens on a local partition. I’m searching through another one of my source directories and it simply doesn’t find files more than 2 levels deep.

For example, on my Leaf project I have several .lfb files. I search /src/leaf/file and it sees no files. /src/leaf/file/share, no file, /src/leaf/file/share/unit_tests/ no files. Then when I search /src/leaf/file/share/unit_tests/block I get 451 files found. This is the point where two levels down .lfb files start appearing.

Does the same issue happen when restarting in safe-mode? Help > Troubleshooting > Restart in safe-mode.

Yes/no. My first search worked, so I then restarted in normal mode and search worked. Then it started failing again. I think I know when it stops working.

Under a document there is a folder listing. If I click on one of those folders there is the option “Find in Folder”. I choose that and the search opens. After this point the search appears limited to 2 folders deep. This restriction remains even if I choose “Edit|Find In Files” again.

Just to clarify, once you have selected Find from the context menu of a folder in the Places Widget, the Directories field will be populated even if you do Edit > Find in Files?

This is expected behavior. We would have 3 options here:

  1. Leave field blank and let user select a directory
  2. Assume project root or Places root
  3. Use last used Directories parameter (this is what Komodo does now)

If you’re selecting Edit > Find in Files I actually think that option 2 makes the most sense.

Hopefully I’ve interpreted your issue properly @mortoray.

  • Carey

Yes, the Directories is populated still… but I don’t see how that’s related. The problem is that the search depth is limited to 2, not that the field is populated. Even if i modify that field the depth is still limted to 2.

I actually expect the field to be left as is until I choose a new directory.

Have you verified that when the bug occurs that all the parameters in the find dialog are correct?

Yes. I’ve retyped the directory and scanned over the other parameters… unless there’s a hidden Advanced options dialog I don’t know what else I could change.

Note that it does find stuff in the 2levels it finds, if the search matches. So it’s not like my filters, or search, are compeltely wrong.

Can you reproduce the issue with these steps when you run Komodo in safe-mode?

No. In Safe-Mode it appears to always work.

Is there some way I can export what preferences I chose so you can investigate what setting is somehow breaking search?

Hey @mortoray,

We don’t provide an UI for this but you could try moving your Preferences file aside to make sure it’s the global preferences (safe mode removes prefs, addons and anything in your toolbox). This tutorial explaining where your user profile is should help with that:

You can then either go with the reset prefs, or go through your preferences and try and find what might be causing the issue.

We would also be interesting in trying to reproduce the issue if you find that it’s your preferences file.

  • Carey