Failing to install Komodo IDE 9.2 on a linux machine


I’m having a problem with python “hashlib” module while installing komodo ide,

ERROR:root:code for hash md5 was not found.
Traceback (most recent call last):
  File "/remote/home/komodo_intall/Komodo-IDE-9.2.1-87651-linux-x86_64/INSTALLDIR/lib/python/lib/python2.7/", line 139, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/remote/home/komodo_intall/Komodo-IDE-9.2.1-87651-linux-x86_64/INSTALLDIR/lib/python/lib/python2.7/", line 91, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type md5

I’ve swapped lib folder of the komodo installation package with installed activestate python lib to make it work. problem with hashlib has solved but instead new once came up

/usr/bin/execstack: Could not set security context for /remote/home/komodo/lib/mozilla/komodo: Operation not supported
chcon: failed to change context of /remote/home/komodo/lib/mozilla/ to system_u:object_r:texrel_shlib_t: Operation not supported
chcon: failed to change context of /remote/home/komodo/lib/mozilla/ to system_u:object_r:textrel_shlib_t: Operation not supported
chcon: failed to change context of /remote/home/komodo/lib/mozilla/ to system_u:object_r:shlib_t: Operation not supported
chcon: failed to change context of /remote/home/komodo/lib/mozilla/ to system_u:object_r:s0: Invalid argument
install: error: could not set SELinux security context for '/remote/home/komodo/lib/mozilla/': 'texrel_shlib_t', 'textrel_shlib_t', 'shlib_t', 's0' contexts failed

What is the reason for this and how to solve it?!

Rather than try and solve the problem that arose from a hack I would suggest we go back to the first problem we’re facing; the unsupported hash type error.

Could you try installing libssl1_0_0, as suggested here?

This is most likely related to this bug.

Hi there,

Sorry for late respone, I’ve upgraded my redhat version from 5 to 6.2 and tried to reinstall komodo, now the python issue has gone itself without any twicks but the second one still remains.

This time I can run and even use Komodo IDE 9.2, on the first run I have this error message:

1445845774152	addons.xpi	WARN	Exception running bootstrap method install on TypeError: Unknown preference type: undefined (resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///opt/komodo/9.2.1/lib/mozilla/extensions/!/bootstrap.js:169:18) JS Stack trace: set@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///opt/komodo/9.2.1/lib/mozilla/extensions/check-compatibility@bootstrap.js:169:19 < install@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///opt/komodo/9.2.1/lib/mozilla/extensions/check-compatibility@bootstrap.js:56:9 < install@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///opt/komodo/9.2.1/lib/mozilla/extensions/check-compatibility@bootstrap.js:212:9 < XPI_callBootstrapMethod@XPIProvider.jsm:4436:9 < addMetadata@XPIProvider.jsm:3332:1 < XPI_processFileChanges@XPIProvider.jsm:3441:23 < XPI_checkForChanges@XPIProvider.jsm:3602:34 < XPI_startup@XPIProvider.jsm:2090:25 < callProvider@AddonManager.jsm:208:12 < _startProvider@AddonManager.jsm:667:5 < AMI_startup@AddonManager.jsm:821:9 < AMP_startup@AddonManager.jsm:2399:5 < AMC_observe@addonManager.js:55:7

There is no error on the second run anymore
To replicate the error I have to remove ~/.komodoide/9.2 folder

Are there any issues actually using Komodo?

As long as i use IDE, it did not crash and does everything i need, but i cant say if some issues will occure because of this

Given the error you’re seeing you may not be able to install outdated addons, but other than that it should not affect the running of Komodo.