Extremely slow when handling large (>10M) text file of chinese characters


#1

Almost unusable. Is there any solution to this? Thanks!


#2

I don’t think komodo is designed for that. I guess even sublime will suffer on such a huge file.


#3

Hi @agroszer Thank you for your comment! Then let me give it up.


#4

I assume Komodo prompted you with the “this file is too big, I’m turning everything off and treating this file like a *.txt file” window? If not, you could try doing that manually. You can change file language in the top right of the files view.

Another trick you could try would be to turn on View > Word Wrap. Scintilla (the underlying editor component) has a very hard time with long lines. This can slow Komodo down even when the file isn’t that big.

Other than that though, @agroszer is right, you’ll have a hard time finding any editor that can reasonably work with files that big.

Can I ask what your use case is?

  • Carey

#5

Hi @careyh Thank you for your reply!

I got no prompt you described. I did set languge to .txt file and turn on Word Wrap, and need to be very careful in handling everything to get the job done.

What I want to do is simply text mining, etc. marking or modifying certain clauses by RegEx.

It seems that a simliar big file containing only english characters does not have the issue.


#6

@surfactant, if that prompt was never displayed, you could also try disabling all the code intel features, and syntax checking to try and speed things up.


#7

Hi @careyh Thank you for your suggestion!