ERROR: install: [Errno 13]

Greetings to everyone,

I tried to install Komodo Edit on Fedora Linux. The script ended with following message:

2014-04-29 00:11:06,574: ERROR: install: [Errno 13] Permission denied: '/etc/selinux/targeted/contexts/files/file_contexts.local.bin'

Tested three times with the same result. However Komodo seems to work fine despite this error during installation. It has something to do with SELinux, may be anyone would know how to avoid this error in the future?

PS: I’ve also tried to run installer as root, but (as far I remember) the installing script ended with multiple errors and the Komodo Edit was not installed at all.

Change chmod for /etc/selinux/targeted/contexts/files/file_contexts.local.bin (chmod 777 /etc/selinux/targeted/contexts/files/file_contexts.local.bin).
Also, please, send me a errors that you get when you trying to install Komodo by root.
PS: Where are you from?)

It is generally not a good idea to chmod files to 777 (giving everyone on the system access to it), especially when it involves security sensitive files (which selinux files definitely are).

If Komodo runs fine despite the error then I wouldn’t worry too much about it. Keep in mind Komodo is built to be cross-platform, and with the huge amount of Linux distributions out there it’s bound to cause a few warnings or unimportant errors on occasion.

Regardless, we’ll have a quick look into this - but I wouldn’t worry about it.

After installation change chmod to 555 or smth like this. Huh.

That would revoke selinux from writing to it’s own files … :wink: I think you meant 655.

Still, best to avoid messing with these permissions altogether - it should not be necessary to install Komodo.