Error Determining PHP Version

[2014-09-22 00:02:01,323] [ERROR] koAppInfo: Caught PHP execution exception. Cmd:[u’c:\\php\\php.ini’, ‘-q’, ‘c:\\users\\jordan\\appdata\\local\\temp\\tmpkgwqsx.php’] in None, exception:%1 is not a valid Win32 application
[2014-09-22 00:02:01,323] [ERROR] koAppInfo: could not determine PHP version number for ‘c:\php\php.ini’:

I’m having trouble getting PHP 5.4.33 installed for use in Komodo IDE 8.5 with Windows 7 Pro. I have enabled IIS, and used the MSI installed for PHP with FastCGI… and Komodo is giving me the above error when I try and enable PHP and syntax checking.

Somehow you’ve configured Komodo to try and run php.ini instead of php.exe - so check your Komodo Languages > PHP preferences and ensure your PHP interpreter is correct.

1 Like

Thanks for the reply toddw. I redirected Komodo to us this interrpreter:

And then I directed it to the PHP.ini file:

I see in the Troubleshooting guide that it recommends php.ini be in the Windows directory. Am I missing something, or breaking it by putting everything in the C:\php folder?

Generally you shouldn’t need to specify any php.ini file in Komodo, as your PHP installation (the php.exe you point Komodo to use) will already have it’s own custom php.ini file.

Komodo (including the troubleshooting guide) doesn’t (or shouldn’t) recommend where to put a php.ini file (that’s for the php installation to do the correct thing) - though it may state where the common locations for php.ini files are found.

Note that the adding of xdebug settings to the php.ini file (in Komodo’s documentation) is only for remote debugging (i.e. for a web server, to initiate debugging of a web page on demand - e.g. IIS, or Apache integration).