Editor pane left margin too big

The editor pane left margin has suddenly got too large.


Without line numbers and with no folding showing I have:

I am sure there is a way to tell scintilla (?) to reduce its margins. Perhaps some sort of about:config file somewhere. I’ll just add a third pic with line numbers and folding showing:

What version of Komodo are you using?

That was 8.5.0. I have upgraded to 8.5.3 since posting but I still get the large margins

I think it’s possible to change margin with Stylish for Komodo (but you must know id for this editor pane, for this you can use DOM Inspector).

Maybe, but I have no idea how to use Stylish for Komodo. There seems to be no documenation!

Just try to drag’n’drop xpi file of Stylish plugin in the Komodo window? I think @nathanr can say more about Stylish for Komodo.
Also get used to not all was or will be has documentation :blush:

Yeah I can load the plugin … that bit is easy. You are right about documentation of course, sad to say :frowning:

Working around the issue with Stylish is not really “solving” the issue.

@peter2108 was there anything that could have prompted this change in margin size? Did you change a pref or install something?

The only unusual thing I have dome recently is use Komodo to read some big data files (60Mb) - they were far too big for RStudio to read.


In IDE version in left pane you can setup breakpoints so it’s a space for this markers, I think.

Yes thats true. But the numbers in my first pic are crazy. I am sure Komodo did not use to look like that, and (if its still usinjg scintilla) there are complicated margin options which may have been scrambled.

Ah that’s interesting, judging from that it may be that Komodo somehow got stuck on the margin size it used for a large file (ie. one that has a lot of lines).

@toddw could you chime in?

As a workaround for now I would suggest trying out the Komodo 9 nightly, the way that the margins are caclculated has changed in this verison: http://komodoide.com/download/#preview

I installed the 9.0 nightly but it appears to have same effect. Perhaps it is not a bug but a feature and only looks weird when there is nothing to put in the margin. For instance here there is just a single space left (8.5.3)

Eh it seems your breakpoint margin is overlapping your “collapse line” margin. Is that screenshot from Komodo 8.5 or 9?

I’m not sure what could have caused this, are you using any macros/addons?

Try deleting your view-state.xmlc and doc-state.xmlc files from your profile directory, I’m not certain these files cover the margins but its worth a shot.

Otherwise try deleting your prefs.xml, just as a test. Be sure to make a backup first.

If all of this still fails I’d recommend either waiting for @toddw to weigh in or delete your profile folder to start anew with a fresh install (make a backup first). If you delete your profile folder you might be able to simply copy back your prefs.xml in order to preserve most of your preferences.

From 8.5. I’ll try your suggestions. Here is another view:

Edit I tried these deletions but they did not chnage anything. We’'ll see if toddw has any suggestions though, when all is said and done it is hardly a blocking issue :smile:

Many thanks for your time!