Edit Line Positioning Issue

I’m having a new (silly) problem and I’ve searched the forum but haven’t hit on the solution.

When I edit a file that has long lines, and I slide the scroll bar to position my lines on the screen where the end of the line is viewable, and I then start inserting characters, the line is moved to the right side of the screen (either the left side of the minimap or edge of the screen if the minimap view is turned off), and any additional characters are added at that position and the line shifted left one character as each character is added. So I can’t see any characters to the right of where I’ve been positioned since the position is up against the right side of the screen.

For what it’s worth, this behavior didn’t start happening until I updated to version 10.2. My build info is:

  Komodo IDE, version 10.2.0, build 89833, platform win32-x86.
  Built on Fri Feb 17 15:10:04 2017.

I’m assuming that this is a setting, but I can’t find a setting that describes this behavior.

Any pointers would be greatly appreciated.

Hi, the preference you are looking for is Edit > Preferences > Editor > Scrolling > Minimum number of columns to keep after cursor. We added this preference recently via https://github.com/Komodo/KomodoEdit/issues/224

OK. Well that’s rather clunky, but at least it solved the “I can’t see characters to the right” issue…