Don't show hidden files in Mac OS X


I’m using Komodo IDE in Mac OS (Mavericks) and it works great, but every time I open a file, the file dialog that opens to select the file shows all the files, including the hidden ones; is it possible to not show the hidden files?

Please notice that I’ve configured the Finder app to not show hidden files, the only place that shows them is when using Komodo IDE.


Komodo shows hidden files because while it may be relevant not to show them in Finder this is often not the case when working on software projects.

You can still hide those files by going into your project properties and adding .* to “Files and directories to exclude”.

Do I have to do it on a project basis? What if I’m not using any project? Isn’t it possible to configure this globally?

BTW, I’ve included .* in Places|Specify the default view filters|Files and directories to exclude but it didn’t do anything :frowning:

You can exclude files globally under Prefs > Places.

You may have to reload your Project for the change to take effect.

Yes, that’s what I did but didn’t worked, I don’t have any project currently open (just editing a perl script), I’ve even closed and reopened Komodo but I’m still seeing .* files when trying to open a file.

Ah for that you need to edit Prefs > Fast Open.

I did that also but still didn’t work :frowning:

Here’s the dialog box, you can see the .* files there:

Ah, I thought you were talking about the Fast Open dialog (cmd+shift+o).

@toddw can you weigh in?

Komodo’s open file dialogs have been set to show hidden files by default (no matter what your Finder is set to use).

To disable this behaviour, you’ll need to do some Komodo pref tweaking - the details are in this bug here:


This worked perfectly! Thanks Todd and Nathan for your help! :smile:

Direct link to “fix”:

(for anyone landing here in the future)