Does the publish->push work differently than last week?

I have always had the option to select Publishing->Push to force a file to the server. On the latest 9.0.0 the option is grayed out. Is there some special circumstance that needs to be satisfied, or is it broken?


Can you please verify your publishing prefs, see if they are all in order?


The publishing prefs look good. They were working normally when the latest 9.0.0 came. After the upgrade I restarted, and the push and diff options are grayed out on all of my projects. I built another project, and it has the same issue.

In addition, but probably separate, since I have to use the Publish tool, I find that one file (a large css file) always shows modified on the remote. Only that file out of around 1000 files in the project.


When was the last time you updated prior to this update? Do you happen to know the build number you were using where publishing last worked properly for you?

I just tested this locally and am not able to reproduce the issue.

Please try adding your publishing configuration again to see if that fixes your issue?

I deleted the configuration and built a new one with a different name. Same result.

I am on Komodo IDE, version 9.0.0, build 87158, platform macosx.
Built on Tue Mar 17 02:17:46 2015.

Previously I installed 87122 at 8:10PM on Monday, March 16, and had no problems that I am aware of. With the latest one I did have to reinstall my license file.

Not sure if it matters, but I’m using scp to move the files. I rebuilt the server config with FTP instead of scp and it does the same thing.

What the menu looks like after building a new publish pref:

I’m a bit confused as build 87158 has a license issue. You just updated and ran it without any issue?

Let me know if using ftp (or sftp) resolves your issue.

I updated to 87158. It told me I had to get a new license. I went to the website and downloaded the OS X license installer for my v8.5, ran it, and all appeared to be well.

Ftp did not work, but I just went back to 87122 and it doesn’t work there in scp or ftp. I built the server and the profile with no project open, so how does it know to use a particular profile to push from the context menu?

Does using a project make a difference for you?

Of course I didn’t mention that this is a brand new computer, and the first thing I installed was Komodo IDE on Monday. Duh.

Now I removed all Komodo and Active state directories, removed the app and installed

Komodo IDE, version 9.0.0, build 87163, platform macosx.
Built on Wed Mar 18 02:19:09 2015.

I deleted the project files, and started from scratch:
Loaded Komodo IDE.
Created a project from existing files and left it open.
Created a server profile for a hosting box to use scp.
Created a publishing profile. The synchronize function works perfectly.
The context menu is still grayed out.

If it matters, the computer is a Mac Pro Quad-core with 64GB RAM.

Does Tools > Publishing work properly?


Can you try running Komodo from terminal with a temporary new profile?


komodo # or `open /Applications/Komodo\ IDE\` perhaps, on OSX

Tried it, and with or without opening a project, they stay grayed out.


Can you share the root paths involved? We had an issue in Publishing several months ago where certain paths were gumming things up.

  • Carey

PS. Thanks for your patients! We’ll get you sorted out.

If that means the prefs for the publishing for this project…

  <boolean id="autopush_on_save">1</boolean>
  <string id="excludes">resources;cgi-bin;logs;*.log;.ftpquota;*.*~;*.bak;*.tmp;CVS;.#*;*.pyo;*.pyc;.svn;.git;.hg;.bzr;*%25*;tmp*.html;.DS_Store;*.swp;*.kpf;*.komodoproject;.komodotools;__pycache__</string>
  <string id="id">07216767-a693-4540-b8d7-ab483146b210</string>
  <string id="includes"></string>
  <string id="local_uri">file:///Volumes/My%2520Book%2520VelociRaptor%2520Duo/dallmon/web/vtr</string>
  <string id="name">VTR</string>
  <string id="remote_uri">scp://DCA12/home/dallmon2/public_html/vtr</string>

Pretty ugly local_uri.

That may be it. I created a new account, publishing pref and project. It worked. The difference is the home folder of the new account. The project local_uri is “/Users/account/Public/test”. The Push and Diff options show up on that account.

It looks like I’m going to have to change the name of my home volume to get rid of the spaces.

Thank you for the help.



If you can lock down reproduction steps, could you please file a bug in Komodo Edit Github repo?

We definitely want a resolution to this issue.

  • Carey

I changed the name of the volume my home directory is on, from “My Book VelociRaptor Duo” to “External”. After rebuilding the project, the “Push” and “Diff” options are now available. I think paths with spaces are not handled well by the publishing code. To recap - the “Synchronize” function works, but the “Push” and “Diff” options on the context menu for each file are grayed out. Removing the spaces in the path fixes the problem.

It was all because I changed my computer on Monday. All is well now. Thank you for your help!


PS Opened Issue #40