Disabling snippets / auto-complete completely?


#1

Is there a direct way to disable auto-completed snippets entirely, either for a current project or for the entire Komodo Edit client?

Based on another HowTo thread here, I was able to individually delete snippets from my Toolbox, but this seems clunky: I might conceivably want those snippets back in some future project, and I’d rather not have to hunt down every individual snippet I currently find annoying to delete it.

I had already tried using Preferences -> Code Intelligence to disable “Enable automatic autocomplete triggering”, “Enable automatic calltip triggering”, and “Enable autocomplete fill-up characters”. Even with all three of those unchecked, my Python project still had snippets popping up.


#2

Hey @rossteh,

That’s not code intel which is where the confusion is arising from. They are “snippets” or auto abbreviations.

You’re looking for Preferences > Editor > Smarting Editing: Auto-Abbreviations.

  • Carey

#3

That’s it! Thanks very much for pointing out the difference.

Part of the reason I hadn’t seen that option myself is that the small UI arrow next to “Editor”, that lets the user know there is a submenu for this entry, is very faint on the default color scheme, and nigh-on-invisible for other darker schemes (like Monokai and Ashes_Dark). This suggestion might not belong in this thread, but it would help to have that arrow more visible!

When I had seen “Editor > Smart Editing > …” mentioned in other threads, and not found the “Smart Editing” option anywhere in my own “Editor” page, I had assumed I was using a different version of Komodo entirely and stopped looking deeper.


#4

You’re not the first person to mention that. Looks like the bug reported by myself fell off the map:

  • Carey