Disable SASS compilation?

it seems like komodo automatically compiles sass and creates .sass-cache folders. This is annoying because then it’s super hard to search from particular style classes -> as most of the results are cache crap.

How do I disable automatic sass compilation - I can’t find that option.


Need more info: Are you talking about in you own project or in Komodo core? The former does not happen natively. The latter can’t be disabled but I doubt this is what you’re talking about.

If you’re talking about your own project you’ll want to try looking at your toolbox for a tool you might have added that’s doing this for you.

Or perhaps you’ve installed this addon: http://komodoide.com/packages/addons/sass-compiler/

  • Carey

I’m using Komodo Ide 9.2. It seems like it compiles SASS by itself?I didnt install any addons like that.


Could you provide more information as to why you think Komodo is compiling your SASS and not something else? Komodo does not ship with this capability. What triggers the compiling of your SASS? Did you look at your toolbox for Userscripts (aka macros) that might be running on file save or Komodo start that would run a SASS compiler?

You could try using the information in on this page to reset your profile and see if the behavior continues: Important File Locations

  • Carey

Hi, in the “Edit -> Preferences” dialog, go to the “Syntax and Spell Checking” section, select the “SCSS” language from the combobox, and select the “None” radio option to disable SCSS/SASS syntax checking (and thus your compilation).

Optionally you could add a filter to your project to ignore those ‘dot’ directories.

I should note that Komodo attempts to use any existing SCSS/SASS interpreter on your path. It doesn’t have one to use on its own.

Thank you very much.

BAH! Sorry about that @cmeth!
Thanks @mitchell!


  • Carey