Disable Cursor Blinking


#1

I would like to disable blinking cursor. Unfortunately, there is no option in the settings for doing it.
I read it was possible to do it with this macros before :

if (ko.views.manager.currentView && ko.views.manager.currentView.getAttribute("type") == "editor") {
    ko.views.manager.currentView.scimoz.caretPeriod = 0;
} 

but it doesn’t work anymore.

I tried to find a way to write a new macro but I don’t find any ways to do it. The API macro is not very clear and I don’t know if I have missed a way to do it. Could you help me ?

I think It would be appreciable to have this option in the settings.

Best regards


#2

Hi, I was able to disable blinking with this macro:

require('ko/editor').scimoz().caretPeriod = 0