Disable auto-completion of language keywords

I’m using the latest 9 beta. What happens is, eg in a Python file, I type

for derp in|

(where | is the cursor)

I get the dropdown of 3 items: input, int, and intern. Those are built-ins.

If I hit space (or tab, as I have configured tab completion) I get ‘input’ completed. That’s annoying.

I think the “real” answer is of course, “break the muscle memory of actually tying your for loops like some kind of animal and use a macro”, but until I can get that wired: is there some way to turn off JUST language keywords?

You could delete them from the Python language file (I’m assuming you don’t want to do that) but there is no preference to remove language keywords.

Once you get used to Auto-Abbreviations they are pretty helpful and they are customizable using EJS. This might be information overload but here is a blog post that covers our Komodo Auto Abbreviations pretty thoroughly.

  • Carey