Debugger not working (it was just mapped urls)

I thought my debugger was working, but it was just because of mapped urls like this :

URL: file://///
Maps to : D:\htdocs\phpacademy\sites\taskbeg\routes\web.php

It stops at breakpoint even if xdebug is disabled on VM.

How to make the remote debugger truly work ?

My xdebug conf in /etc/php/7.1/fpm/php.ini :

xdebug.remote_enable = 0

It is the correct php.ini file (as shown with phpinfo()).

Also :
Using mapped url, I can debug the php running on vm, using host pc komodo listening on specific port 9000.
Strangely, if I change that port to another port, like 9001, it won’t listens (won’t stop at breakpoint).

I’m not sure I follow, you’re saying it always breaks at the breakpoint? So debugging is always working, and your problem is that you wish to periodically disable it?

I mean that I have mapped urls in preference. With those, I can debug without xdebug on the VM.
What I’d like is remote debugging, without using mapped urls.

Maybe this is an important detail :

I’m using a VM shared folder :
Is synced to

Whatever I create locally in D:\htdocs\blabla\sites\taskbeg, will be created in /home/blabla/taskbeg , and vice versa.


How are you starting the debug session?

It works well.

It’s just the proxy that I don’t understand that much. I don’t need it, but I’d like to understand.

From the doc : “Proxy Listener Address: The interface IP address and port Komodo uses to listen for connections from the proxy. By default, the debugger proxy uses port 9000 to listen for remote debuggers and port 9001 to listen for connections from Komodo.”

So :

  • does 9000 corresponds to this : “Komodo should listen for debugging connection on a specific port: 9000”.
  • and 9001 to this : “I am running a debugger proxy and Komodo should use it : Proxy listener address :” ?

IT’s confusing, because on “pydbgpproxy” command screen, I see this :

INFO: dbgp.proxy: dbgp listener on
INFO: dbgp.proxy: IDE listener on

So, in komodo should it be “specific port: 9001”, and “Proxy listener address :” ?

Let’s stick to one topic per thread @trogne. This is already confusing enough as it is. Please answer my question above.

OK. Yes I was starting to debug.

I was confused. It works with normal remote debugger, without a debugger proxy. It’s using mapped urls and that’s normal.


For my previous proxy question, do I start another thread ?

One issue per thread so yes, start a new thread if you want to ask about the proxy.

Can you please summarize exactly what your issue was then set your response as the solution?

Maybe this thread should be closed.

Cause I was mostly confused. I thought that Komodo was debugging (with mapped urls) even though remote debugger was not enabled,

But it was enabled! I was not looking at the right xdebug file first, and I was not restarting the php service (only nginx). I’m used to apache module and only restarting apache. But with the nginx configuration, I needed to restart php service.

Perfect! Thank you @trogne!