Debug window won't pop up when trying to debug perl cgi

Hello everyone,

I’m having a problem using Komodo IDE to debug some PERL scripts which run as CGI in apache. According to the komodo docs, a debug window should open, when I start the script. This doesn’t happen. Even when I run the script from command line with perl -d, there’s nothing happening in komodo. I’ve checked the listening port with netstat and confirmed that komodo is actually listening on port 9000.

As per the documentation, I’ve added the listening port 9000 to the apache configuration with the PERLDB_OPTS directive, and added the -d flag to the shebang of the script.

Here are some screenshots of my settings and also the error log:

I’ve also tried to enable debugger logging, but there is no log file being created in the given path.

I’ve also watched network traffic on port 9000. Here’s a screenshot of what I see:

I hope you can help me with this.


Ca you post the PERLDB_OPTS settings, as well as any other Apache perl debugging setting you added?

This is what have inside <VirtualHost></VirtualHost>:

SetEnv PERL5LIB "/usr/share/perl5:/opt/Komodo-IDE-8/lib/support/dbgp/perllib:/opt/mon-config/lib/mon-config"
SetEnv PERLDB_OPTS "RemotePort=localhost:9000"

Ok, now I think I figured it out. I changed my PERL5LIB from:

SetEnv PERL5LIB "/usr/share/perl5:/opt/Komodo-IDE-8/lib/support/dbgp/perllib:/opt/mon-config/lib/mon-config"


SetEnv PERL5LIB "/opt/Komodo-IDE-8/lib/support/dbgp/perllib:/opt/mon-config/lib/mon-config"

essentially removing “/usr/share/perl5” from it, and now it seems to work!

1 Like

Right - that makes sense - as the special module (included in both the perl standard library and Komodo) is used to launch the debugger - so Komodo’s perl5db module must be found before the perl standard library one in order to debug with Komodo.