Cyrillic and charset

Hello! Help, please.
Debugger mode HTML incorrectly shows the Cyrillic alphabet.
XAMPP use.
php.ini > set default_charset = “UTF-8”
*.php files saved in Unicode


This is a bug or something I do not set up? Spent 3 hours on it to find out. Help, please

Could you try opening the PHP file via your browser, I’d like to find out whether this is a Komodo issue or an issue with your php.ini.

Note the encoding you see in Komodo is that of the file you are editing, it is not for the “html output”.

Also note that your html output appears to be showing response headers, which is what is making me wonder about issues with your php.ini.

It’s not a Komodo or php.ini issue. By default Mozilla try to use CP1251 if you don’t set <meta charset>. Try to insert <meta charset=utf-8> before <?php tag.
Just for testing you can try to use UTF-8 in any html file without <meta charset> and open it in browser like a site (not file://), open a developer console (Ctrl+Shift+K) and in console you can find a warning about using UTF-8 without setting a default charset for browser.

1 Like

Take a screenshot first without ,

and then added

Well done.
As I see at now Firefox (and forks) can detect Russian language and change encoding from CP1251 to UTF-8, nice.
And I think auto-detection of Russian appeared in the Firefox 30+, but Komodo 8 uses Mozilla 24 as far as I remember.
I’m check this in Komodo 9.

There is same problem in IDE9. You must use <meta charset> to property Cyrillic displaying.

1 Like

Interesting, thanks for sharing the solution @Defman, will see if this is something that can be backported into Komodo (auto detecting eg. Russian).