Context menu delays

I’m working on Ubuntu 12.04. Recently, I found there is a significant delay when ever I try to use the right mouse button anywhere in Komodo. There is at least a 5 second delay and the window goes dim. Eventually, the context menu pops-up.

I’m not sure if it is related, but I recently experience some similar behavior with Firefox. I only mention it because I know Komodo and Firefox use some of the same libraries.

I have tried rebuilding codeintel, but it’s not specific to codeintel actions. I also thought it might be a permissions issue so I made sure all Komodo app files and profile files were readable and writeable. Any suggestions?

Also, is Komodo still a supported product?
I see the forums have been archived. All of the sub-forums are labelled ‘historical’. There’s no clear link to I was trolling around Friday and never ended up here. If Activestate trying to send a message for people to look for a new IDE product… message received.

Of course yes.
Also in the bottom of your display on page you can see this:

Hmm… missed that. I think I tune out those kinds of banners (my ad filter). Thanks.

Just the same though. If I can’t get the context menus working again, I’ll still need to look elsewhere. Turns out the top drop-down menus won’t even open.

What version of Komodo you use?

I recently upgraded to 8.5.4, but before I did so I ran a system-wide apt update.

Last night I tried re-installing Komodo 8.5.3 and 8.5.4 in a variety of locations. I did completely clean installs (removing .komodoedit user directory and install directories each time). I generally prefer to install under /usr/lib/Komodo, but I also tried installing under my home directory because I did see some permissions issues popup (pystderr.log) after one of the installs. I’m not seeing those errors anymore, but still seeing significant delay 9-10s before it dims and then another 5s. However, in previous installs the menu (top-drop-downs) would not even show up, now they do after 15s or so, if I don’t leave the window. Keep in mind this is with a clean install, so it’s not codeintel-memory related.

As I’m testing I’m tailing the 2 komodo python logs, but I’m not seeing any activity. What other logs should I be looking in for information?

At this point, I’m convinced one of the recent Ubuntu updates is responsible, but I don’t know which core libs Komodo uses. It is probably one that is shared by Komodo and Firefox. Any ideas?


Komodo and Firefox are both based on Mozilla, so it’s likely some type of conflict between your distro and Mozilla.

Could you try updating to the Komodo 9 pre-release? It uses a new version of Mozilla:

Other things you could try (to narrow down the problem):

Yep. Komodo 9 faster than Komodo 8.5. On my SATA HDD (2TB, 6Gb/s) IDE9 running about 0.5-1s so it’s a good idea to try it. If not - I think something with your PC performance.

Thanks for your reply.

I installed Komodo IDE 9 preview under my user directory (owned by me). As before right-clicking on anything causes a 5+s delay (dimming, etc.), but the menu does open after and is functional.

If I run as root the right-click context menus seem to work fine. So it does feel like a permissions issue, just not with the Komodo application files. Some library outside.

Mozilla Firefox suggested installing a non-repo version of Firefox. Similar deal, except that Firefox was completely unusable unless I ran it as root.

I did read through Firefox bug reports before posting here, all of the issues seemed pretty old, so it was hard to correlate, plus this is a recent issue. Up until this m(little over a week now), Firefox and Komodo were my primary (daily) tools for work.

I tried switching the GTK theme to default (was ambiance) and playing around with these settings. The problem persists, but I think you may be onto something here. I’m looking through apt history for gtk references, but its a little daunting.

I guess the only option now is to run as root or upgrade Ubuntu. How disappointing.


It sounds like you may have some permission issues on your home folder. You could try doing a recursive chown on your home directory (do NOT do this on any other directory unless you know what you’re doing).

Eg. for me this would be chown -R nathan.nathan /home/nathan

You might have better luck posting about this on the Ubuntu forums though, it sounds like it may be a distro specific issue.